MyBB 2.0 İçin Gereken Sunucu Özellikleri Duyuruldu!

MyBB 2.0 İçin Gereken Sunucu Özellikleri Duyuruldu!

Merhaba,

MyBB 2.0 için kollarını sıvayan MyBB geliştirici ekibi, 2.0 ile ilgili gelişmeleri bizlere duyurmaya devam ediyor. Geçtiğimiz günlerde MyBB 2.0 için test sürümünü kullanıma sunmuş, geliştiricilerin 2.0 hakkında bilgi sahibi olmaları ve tavsiyelerini almak istemişlerdi.

MyBB 2.0’ın geliştirilmesi aşamasında bende birçok fikir ve tavsiyelerimi MyBB developer ekibindeki çalışanlar bildirmiştim, bildirmeye devam ettim.

Geçtiğimiz günlerde MyBB’nin resmi sitesinden bir blog yazısı paylaşıldı. Paylaşılan bu blog yazısında MyBB 2.0 için gereken sunucu özelliklerinden haberdar edildi.

O blog yazısını sadeleştirip sizlere aktarıyorum.

MyBB 2.0 İçin Gerekli Olan (İstenilen) Sunucu Özellikleri:

MyBB 2.0’da tamamen alt yapısını ve çekirdeğini güncelledi. En son teknolojileri kullanarak geliştirilen MyBB 2.0 için haliyle bu son teknolojileri çalıştırmak için gerekli olan sunucu özellikleri değişmek durumunda kaldı.

MyBB 2.0’da planlanan yeni özelliklerin rahat entegre edilebilmesi ve tam işlevsel olarak çalışabilmesi için bir takım sunucu özelliklerini değiştirmek gerekti. Bunlardan en önemlisi olan PHP oldu. MyBB’nin en güncel sürümü olan 1.8.7 ‘de php sürümü 5.6 idi.

Gelişen teknoloji ve diğer rakip yazılımlarla rekabet edebilmek adına,2.0’da mybb’nin temel iskeletinin değiştirilmesi ve son teknolojiye uygun hale getirilmesi kararlaştırıldı.

MyBB 2.0 sadece PHP 7.0 ile çalışacak.

Neden PHP 7.0 ? Çünkü; En son php sürümü olması ve en son teknolojilere ayak uydurmak için gerekli olmasından kaynaklanmaktadır. Diğer php sürümlerine nazaran daha hızlı, kolay kullanılabilir olması ve tabii kide güvenlik.

PHP 7.0, diğer sürümlerine nazaran daha sağlam bir güvenlik yapısına sahip. Bu güvenliği sağlarken kullanımı zorlaştırmıyor aksine daha kullanışlı hale getirmektedir. Bu yüzden 2.0 sürümünde tercih edilen php sürümünün 7.0 olarak ayarlanması ve buna göre MyBB kullanıcılarının sahip oldukları sunucu ya da hostinglerini 2.0 sürümüne göre ayarlamaları gerekmektedir.

PHP ‘yi geliştirenlerin diğer php sürümlerinden yakında geliştirme desteklerini çekeceklerini biliyor olmamız bizi yeni çıkan PHP 7.0 sürümüne yönlendirdi. Çünkü; 7.0 sürümü 8 ay önce piyasaya sürüldü ve müthiş bir trend yakalayıp birçok uygulamanın ortaya çıkmasını sağladı ve uzun yıllarda geliştirileceğinden dolayı 7.0’ı tercih etmemizi sağlayan ikinci sebeptir. Bkz: https://secure.php.net/supported-versions.php

MyBB’in iskeletini değiştirip yeni yapı olan Laravel yapısına geçtiğimizden dolayı diğer php sürümlerinde yapamadığımız kodlamaları ve düzenlemeleri 7.0 ile yapabiliyor ve aynı zamanda Larevel yapısına uygulayabiliyoruz buda bu sürümü tercih etmemizi sağlayan üçüncü sebeplerden biridir.

Ayrıca, birçok sunucu ve hosting firmasının artık eski php sürümlerine destek vermemeleri, varolan sunucularınıda son sürüm olan 7.0 sürümüne geçirmeye başlamış olmaları ve biz MyBB kullanıcılarını zor durumda bırakmamak onlara en son teknolojide kaliteli bir MyBB deneyimini yaşatmak için güncel teknolojilere ayak uydurmak durumundayız.

Halen, MyBB’yi çok eski sürümlere sahip sunucularda çalıştırmaya çalışan kullanıcılarımız olduğundan dolayı bu kararı alırken çok fazla tartıştık ve sizler için en iyisi olanı seçtik.

Kaynak: https://blog.mybb.com/2016/08/17/shuttering-of-the-2-0-host-compatibility-repository/

 

Blog yazısında söylediklerinin tam tercümesi sayılmaz ancak okuduklarımdan ve paylaşılan forum konusuna gelen yorumları değerlendirerek ve anladığım kadarını sizler için sadeleştirip aktarmaya çalıştım. Görünen o ki MyBB 2.0 baya köklü ve sağlam bir yapıyla geliyor arkadaşlar. Henüz 2.0 ‘ın çıkış tarihi belirtilmediği gibi çokta uzak olmadığını söylemekteler 🙂

Bir önceki yazım olan MyBB Meta Etiketleri Nasıl Eklenmelidir ? başlıklı yazımda Google Seo, mybb google seo ve mybb meta etiketler hakkında bilgiler verilmektedir.